Mega can't Connect to the App via Bluetooth

This article applies to mBot Mega.

 

1. Issue Description

When mBot Mega tries to connect to mobile device via Bluetooth, the product is not recognized for connection (e.g. the app page stays in a spinning circle searching). Or the Bluetooth connection to the mobile device is successful, but it is frequently disconnected due to operations such as motor operation.

 

2. Possible Causes

  1. Bluetooth module failure.
  2. The mobile device does not enable Bluetooth authorization for the specific app.
  3. Interference from some previously uploaded programs or incorrect firmware version.
  4. Battery problem (battery power is too low/voltage is unstable).

 

3. Troubleshooting Steps

  1. Check whether the Bluetooth module indicator light is normal. The indicator light of the Bluetooth module flashes slowly in blue after power on, and becomes constant blue when the Bluetooth connection is successful. If the indicator light displays incorrectly in different states, you may need to replace a new module.
  2. Enter the mobile device to confirm whether Bluetooth authorization is turned on (operations may differ slightly for different device models)
  • iOS system: Enter the "Settings" section of the mobile device, select "Privacy", click "Bluetooth", and check whether the authorization button of the corresponding app is turned on.
  • Android system: Enter the "Settings" section of the mobile device, select "Privacy Protection", click "Change Bluetooth connectivity" in "Other permissions", and check whether the corresponding app has selected to allow authorization.
  1. If you have uploaded one program to mBot Ranger before, the indicator light of the bluetooth module may display incorrectly when trying to connect to the app via Bluetooth, and an error message "Update the Firmware of mBot Mega" may appear. Please refer to the article "How to Update mBot Ranger Firmware" to refresh and reconnect.
  2. If the product is currently powered a battery holder, please install new Nanfu AA batteries. If the problem persists, you can plug in a USB cable to power the product at the same time, and then test the Bluetooth connection in the App. If the connection is successful at this time, it can be verified that the problem is the battery. It is recommended to use Makeblock rechargeable battery pack.

 

4. Still Need Help?

If the problem is not resolved, please contact us via service@makeblock.com with the necessary details of the fault, such as order number, operation video, device firmware and software version.

 

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