This article applies to mBot Mega.
1. Issue Description
When running line-following related programs or using the line-following function in the Makeblock App, the product does not follow the correct route.
2. Possible Causes
- Firmware version is not correct.
- The sensors are too close to the ground. Pay attention to the installation position of the sensors.
- The ground of the operating environment can't reflect infrared light, or the material of the black line can't absorb infrared.
- The sensors are affected by other light sources, such as a strong light source or infrared light emitted by an infrared remote control.
- The pins of the 3-pin cable are not connected in the expected sequence.
- The signal wires of left and right line-following sensors are connected reversely.
3. Troubleshooting Steps
- If you are trying to run the line-following Mode of the preset programs or this one function in the Makeblock APP, please make sure you restore the product to factory firmware first.
- Check if the installation position of the sensor is accurate, if the screws are loose it may cause this module to shift.
- Please use the map that comes with the product for test. Make sure the ground is not too bright and relatively flat during the test.
- If there is any strong light source or infrared light that may affect the sensor, please turn it off temporarily and keep the normal brightness.
- Follow the picture below to check if the sensor is accurately plugged into the corresponding pin port on the motherboard.
- Refer to the following demo diagram to check if the sensor's different color signal wires are plugged into the correct pin ports.
4. Still Need Help?
If the problem is not resolved, please contact us via service@makeblock.com with the necessary details of the fault, such as order number, operation video, device firmware and software version.
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