This article applies to mBot Ultimate 2.0.
1. Issue Description
When Ultimate tries to connect to a mobile device (phone or tablet) via Bluetooth, the product cannot be recognized (e.g., the app page stays in a circle searching). Or the product successfully connects to the mobile device's Bluetooth, but becomes disconnected due to motor operation.
2. Possible Causes
- Bluetooth module defection.
- The mobile device does not enable Bluetooth authorization for the corresponding app.
- Interference from previously uploaded programs or wrong app/firmware version.
- Battery holder or battery problem (low battery power/unstable voltage).
3. Troubleshooting Steps
-
Please check whether the indicator light of the Bluetooth module is normal after power on. The indicator light of the Bluetooth module flashes slowly in blue after turning it on, and turns to constant blue after the Bluetooth connection is successful. If the indicator light displays incorrectly in different states, you may need to replace a new module.
-
Verify whether the Bluetooth authorization of the app is enabled on the mobile device (operations may vary slightly on different devices)
-
IOS system: Enter the "Settings" section of the mobile device, select "Privacy", click "Bluetooth", and check whether the authorization button of the corresponding app is turned on.
-
Android system: Enter the "Settings" section of the mobile device, select "Privacy Protection", click "Change Bluetooth connectivity" in "Other permissions", and check whether the corresponding app has selected to allow authorization.
-
If you have uploaded one program to Ultimate 2.0 before, an error message "Firmware cannot be recognized" may appear when trying to connect to the app via Bluetooth. Please refer to the article "How to Update Firmware for Megapi" to refresh. If the issue does not appear in other apps, please reinstall this app and try to connect again.
-
If the product is currently powered 6AA battery holder, please install new Nanfu AA batteries. If the problem persists, you can plug in a USB cable to power th e product at the same time, and then test the Bluetooth connection in the App. If the connection is successful at this time, it can be verified that the problem is the battery. It is recommended to use Makeblock rechargeable battery pack.
4. Still Need Help?
If the problem is not resolved, please contact us via service@makeblock.com with the necessary details of the fault, such as order number, operation video, device firmware and software version.
Comments
Please sign in to leave a comment.