Unable to Upload Program Successfully

This article applies to all of Makeblock's current products that can be connected to mBlock software.

 

Issue Description

When trying to upload a program to product in the mblock software, the progress bar does not change and the corresponding error report appears, as shown in following pictures.

 

Possible Causes

1.  The product's Power Switch is not turned on.

2.  The wrong device extension was selected. For example, you choose Bot Neo device extension and connect to it, but the actual product model is mBot.

3.  The created program is incorrect.

 

Troubleshooting Steps

1.  Please make sure the machine's Power Switch has been turned on.

2.  Since the computer can only recognize the device COM port, but recognize the exact machine model. Please confirm that the device extension added in mBlock matches the model of the machine you are using.

3.  If the above steps are correct, please provide us with the complete program file and the operation process video showing the error details. We need to check and test whether the program is completely correct.

 

Still Need Help?

If the problem is not resolved, please contact us via service@makeblock.com with the necessary details of the fault, such as order number, operation video, device firmware and software version.

 

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