This article applies to all Makeblock product models that support connecting to the mBlock software, such as the mBot, mBot Ranger, mBot Mega and others.
Issue Description
When you try to connect the product to the computer via USB, you may see the following anomalies displayed on the mBlock page:
-
The connect button is grayed out (“No device can be detected to connect” or “Scanning serial port in progress”)
-
The COM port is detected but there is an error message like ‘Connection failed’.
Possible Causes
-
Faulty USB cable or computer port
-
CH340 driver is not installed correctly or does not work
-
Computer port is occupied
Troubleshooting Steps
1. Please check if the Makeblock USB cable used is visibly damaged. If you have a spare cable with data transfer capability, you can use it to test it. In addition, if you have other computers, it is better to test it with a different device as well. If you are not sure whether your cable supports data transfer, please refer to the steps in the figure below.
2. Please open your computer's Device Manager, click on Ports (COM&LPT) to expand the list, and check whether CH340 is displayed normally, as shown in the following picture.
- If the driver cannot be displayed, or if there is a yellow warning sign on the left side of the column, please enter the website and reinstall the driver: CH341.SIGN.zip
- If the driver can be displayed normally but mBlock still can't recognize the port, please disable the security software and firewall temporarily and then reinstall the latest mBlock software: https://mblock.cc/pages/downloads . Or you can directly enter the web version mBlock to operate: https://ide.mblock.cc.
3. If your computer is connected to other devices at the same time, please temporarily disconnect the other ports and then test.
Still Need Help?
If the problem is not resolved, please contact us via service@makeblock.com with the necessary details of the fault, such as order number, operation video, device firmware and software version.
Comments
Please sign in to leave a comment.