This article applies to mBot.
Products with Bluetooth function can be connected to the computer or mobile device via Bluetooth, and this article will explain the connection abnormality for different devices separately.
Issue Description
When the product tries to connect to a computer or mobile device via Bluetooth, it shows can't find the device Bluetooth in the software page, or the app stays on the page that keep searching for the device.
Sample images as follow:
一. Can't connect to the mBlock software?
Possible Causes
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The Bluetooth module is damaged.
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Windows computers cannot successfully connect to mBot via Bluetooth if the built-in Bluetooth protocol of the computer is not standard 4.0 version.
Troubleshooting Steps
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Check if the indicator light of Bluetooth module is normal. The indicator light of Bluetooth module flash blue after power on, and becomes stay blue after successful Bluetooth connection. If the indicator light of the Bluetooth module shows incorrectly after powering on, the module may have been damaged.
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Install the standard 4.0 Bluetooth driver: https://support.makeblock.com/hc/en-us/articles/13418871832599-Bluetooth-Compatibility . You can also directly connect to web version mBlock, there is no Bluetooth version limitation: https://ide.mblock.cc/
二. Can't connect to the APP?
Possible Causes
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Bluetooth module is defective
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The mobile device does not enable Bluetooth authorization for the corresponding app
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The battery voltage or current is too low
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Being interfered by some previously uploaded programs
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Hardware or software compatibility issues or temporary bugs occur in the app
Troubleshooting Steps
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Check if the Bluetooth module indicator light is normal. The Bluetooth module indicator light will flash blue slowly after power on, and becomes constant blue after successful connection. If the Bluetooth module indicator light is wrong after powering on, the module may be damaged.
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Refer to the following steps to confirm that Bluetooth authorization is enabled.
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IOS system: Enter the “Settings” section of your mobile device, select “Privacy”, click “Bluetooth”, and check whether the authorization button of the corresponding app is turned on.
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Android system: Enter the “Settings” section of your mobile device, select “Privacy Protection”, then click “Change Bluetooth connectivity” in “Other permissions”, and check whether the corresponding app has been selected to allow authorization.
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You can power the product via USB cable at the same time, and then test the Bluetooth connection in the app. If the connection is successful at this time, it will be verified that it is due to the battery. We recommand you replace them with brand new NANFU AA batteries or use Makeblock lithium battery pack.
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If you have uploaded a program to mBot before, when you try to connect to the app via Bluetooth, the indicator light of the Bluetooth module may show abnormality and an error “Firmware not recognized” may appear. Please refer to “How to Update mBot Firmware” to update the machine to the online firmware first and then try to reconnect.
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Download and install the application again.
Still Need Help?
If the problem is not resolved, please contact us via service@makeblock.com with the necessary details of the fault, such as order number, operation video, device firmware and software version.
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